UV Sterilizer or Filter with a Sterilizer light

More
22 Aug 2016 08:56 #1 by Ahsan225 (Syed Subhan)
hi,

I am having water clarity & Algae issues. parameters are: ammonia, Nitrites 0, Nitrates were 40 ppm. I have put a bag of JBL Nitratex in the filter and it came down in the space of 2 hrs. guys at seahorse advised i need some uv sterilization in the tank ( 65 euros for the kit they showed me) to treat green algae. I looked online and allpondsolutions do an internal filter with a 9w uv light for the same price.

www.allpondsolutions.co.uk/aquarium/filt...lh-with-9w-uv-700if/

what would you guys advise on this

Kind regards,

Syed

Please Log in or Create an account to join the conversation.

More
22 Aug 2016 12:20 #2 by robert (robert carter)
Hi , is this a tropical tank , if so what i do is add daily liquid co2 and get so little algae only need to clean the glass every 3 weeks , i have started adding liquid co2 to my coldwater tank that has artifical plants in it plus 4 very small bristlenose plec because of the fastbuild up of algae now aweek later not a bit of algae in the tank

Please Log in or Create an account to join the conversation.

More
22 Aug 2016 12:54 #3 by Ahsan225 (Syed Subhan)
with discus in my tank, I am not entirely sure adding CO2 is a good idea ?

Please Log in or Create an account to join the conversation.

More
22 Aug 2016 12:54 #4 by Ahsan225 (Syed Subhan)
Also, I am thinking, a UV filter / sterilizer will improve the overall water quality as well ?

Please Log in or Create an account to join the conversation.

More
22 Aug 2016 15:27 #5 by robert (robert carter)
Ok understand your situation , all i can tell you is that i have dealt with All Pond Solutions for years and never had a problem with anything i purchesed from them , in fact you will that i recently purchased a pressure filter from for my koi pond .

Please Log in or Create an account to join the conversation.

More
22 Aug 2016 16:36 #6 by ger310 (Ger .)
I don't know what your water clarity issue is but a couple of Bristlenose Pleco's would sort out your algae problem........I can give yeh a couple for nothing if your anywhere near the Santry area.

Is it tiny particles floating around the tank your clarity issue? if so filter floss could solve that.

Ger

What do you call a three legged Donkey?

A Wonkey....duh ha :)

Please Log in or Create an account to join the conversation.

More
23 Aug 2016 09:34 - 23 Aug 2016 09:34 #7 by Ahsan225 (Syed Subhan)
this is the greenish tinge i am dealing with. I cleaned the filters in tank water on Friday (internal jewel filter). water was clear before that.


drive.google.com/open?id=0B2iFlddDfSj3YXNGX0pGNmx6Z0U

@Ger310: Much appreciated. Can I have your number for a quick chat please?
Last edit: 23 Aug 2016 09:34 by Ahsan225 (Syed Subhan).

Please Log in or Create an account to join the conversation.

More
23 Aug 2016 09:40 #8 by alan 64 (alan)
How many hours are ur lights on and how.much are u feeding the fish i would be more concerned with ur natrates readings than ur green water as u are keeping discus

Please Log in or Create an account to join the conversation.

More
23 Aug 2016 10:25 #9 by Ahsan225 (Syed Subhan)
Nitrates are back to normal levels now.. I have nitratex in the tank to keep it in check. I have cut down on feeds to 2x daily no beef heart.
Light is on approx 8 hrs daily.

Please Log in or Create an account to join the conversation.

More
23 Aug 2016 13:59 #10 by alan 64 (alan)
u need to be aiming for o nitrate levels without using the likes of nitratex how many times a day were u feeding them

Please Log in or Create an account to join the conversation.

More
23 Aug 2016 14:31 #11 by Ahsan225 (Syed Subhan)
i was feeding them 2 - 3 times ... now down to 1 feed a day until things are in control.

Please Log in or Create an account to join the conversation.

More
23 Aug 2016 21:17 #12 by alan 64 (alan)
Id presume the high nitrates are y u got the algea bloom

Please Log in or Create an account to join the conversation.

More
23 Aug 2016 22:35 #13 by ger310 (Ger .)

Ahsan225 wrote: @Ger310: Much appreciated. Can I have your number for a quick chat please?


I'l PM that to you now ok.

Sorry I thought you were having algae trouble on your glass/plants/stones etc. but the offer still stands with the Bristlenoses ok............is it a new set up? as an algae bloom like that would be quite common in a new set up.............as Alan said it could be your Nitrates but even when at 40ppm it's not that big of a deal to be honest and it could be 101 things that cause it...............keep feeding to a minimum and do large daily water changes and it should hopefully clear itself up in a few days.............don't spend any money on any equipment just yet though ok.

Ger

What do you call a three legged Donkey?

A Wonkey....duh ha :)

Please Log in or Create an account to join the conversation.

More
24 Aug 2016 05:55 #14 by Ahsan225 (Syed Subhan)
i am have started doing a 25% wc as of yesterday.. lets see how it goes..will also add a nitrate removing sponge to my juwel filter. feeding is at once a day tetra discus flake.. fingers crossed :)

Please Log in or Create an account to join the conversation.

Time to create page: 0.110 seconds
Powered by Kunena Forum